Transform Bundle

Questions?

Contact Phantom48 Customer Support.

Waves Transform Bundle

$299.00
Fast Electronic Delivery

The Transform Bundle is delivered electronically. Order now and Phantom48 will e-mail you an official Waves license code with download and registration instructions. Electronic delivery orders are normally processed within one business day or less.

You want to push the envelope. Take creative control. And twist your sound inside out like never before. You need Transform, five state-of-the-art processors that let you stretch and ...More Info

Details

You want to push the envelope. Take creative control. And twist your sound inside out like never before. You need Transform, five state-of-the-art processors that let you stretch and manipulate time, pitch, dimension, and punch. Get ready for sonic metamorphosis, get ready for Transform.

Included plugins:

  • TransX
  • SoundShifter
  • Morphoder
  • Doubler
  • Renaissance Axx

Details

System Requirements

  • Intel Core i3 / i5 / i7 / Xeon
  • 4GB RAM
  • 4GM free disk space
  • Minimum Screen Resolution: 1024x768

Mac

  • 10.9.5 - 10.12.1
  • 10.8.5 for ProTools 10 only

Windows

  • Windows 7 with SP1 64 bit
  • Windows 8.1 64 bit
  • Windows 10 64 bit

The Waves Central application and Waves plugins V9.6 or later are not compatible with Logic 9 or Mac OS Lion 10.7 to 10.7.5

Details

{{block type="cms/block" block_id="emaildelivery" template="cms/content.phtml"}}

Description

Details

You want to push the envelope. Take creative control. And twist your sound inside out like never before. You need Transform, five state-of-the-art processors that let you stretch and manipulate time, pitch, dimension, and punch. Get ready for sonic metamorphosis, get ready for Transform.

Included plugins:

  • TransX
  • SoundShifter
  • Morphoder
  • Doubler
  • Renaissance Axx

Requirements

Details

System Requirements

  • Intel Core i3 / i5 / i7 / Xeon
  • 4GB RAM
  • 4GM free disk space
  • Minimum Screen Resolution: 1024x768

Mac

  • 10.9.5 - 10.12.1
  • 10.8.5 for ProTools 10 only

Windows

  • Windows 7 with SP1 64 bit
  • Windows 8.1 64 bit
  • Windows 10 64 bit

The Waves Central application and Waves plugins V9.6 or later are not compatible with Logic 9 or Mac OS Lion 10.7 to 10.7.5

E-Mail Delivery

Details

{{block type="cms/block" block_id="emaildelivery" template="cms/content.phtml"}}